Normal operating temperature for 147 1.6 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 18-10-13 Thread Starter
Status: -
Join Date: Oct 2013
Location: United Kingdom
County: Surrey
Posts: 7
Normal operating temperature for 147 1.6

Hi all,

I've recently bought my first Alfa, and its going great! (I get it now!)
I've got a few questions about this car that I've never had on any of my other cars - A very efficient cooling system

My car takes at least 3-5 minutes to start hitting '60' on the temperature sensor, and will go up if I drive erratically and go down if I'm smooth. Is this normal for 1.6 147's, or do I need to fix something?
Hugginator is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,993
90degC is what you want to see all the time once the engine has warmed up.

Running cold is usually the thermostat failed and sticking open.
David C is offline  
Status: Chillin
AO Silver Member
Chocoboy's Avatar
Join Date: Dec 2009
Location: United Kingdom
County: Nottinghamshire
Posts: 5,621
Images: 13

Member car:

2005 147 JTD

yep sounds like a duff thermostat.
Chocoboy is offline  
Status: -
AO Member
Join Date: May 2010
Location: United Kingdom
County: Kent
Posts: 43
Yup sounds like the thermostat. I'd recommend changing the temperature sensor too (attached to the thermostat). I changed my thermostat on my 1.6 but neglected the temp sensor, ended up with weird erratic revving issues. It's one of those things you might as well change as it's out
Insomnia is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , cooling , normal , operating , temperature

« Oil Cooler | Sad GT »
Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome