Help squeaking 156 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 15-05-06 Thread Starter
Status: -
Join Date: Apr 2006
Location: Norwich
Posts: 5
Help squeaking 156

My 156 Sportwagon has developed a squeaking noise from the f/n/s suspension (sounds like a dry joint?). This only occurs when I have driven her for awhile and she is warmed up. Any suggestions!!
the meadows is offline  
Sponsored Links
Status: here to help!
AO Member
Join Date: May 2006
Location: United Kingdom
County: West Yorkshire
Posts: 362
Images: 7

Member car:

Volvo 855 T5r

Re: Help squeaking 156

very strange!!, my `01 156 jtd, does the same, but only when cold, goes away after about 10/15 mins of driving when the car/chassis seems to have "warmed up", had mine checked at garage and they could`nt find anything wrong!!
cragmaz69 is offline  
Status: -
AO Member
Join Date: Dec 2005
Location: Copenhagen DK
Posts: 120
Re: Help squeaking 156

I had the same problem on my 166 2.0 TS. Took it to the garage and it turned out not to be an uncommon problem. The culprit is often the front suspension wishbone upper swingarm. The garage greased and the noise went away. But that is now 8 months ago and the squeaking came back. But this time it goes away after some kms of driving. The garage tells me then its the probably the lower swingarm this time- but of course the need to see it first to be sure. A lot of bits which can start squeaking. Anyways not an expensive in Denmark at least. Will have it checked this friday
Bjerregaard is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , squeaking

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome