radio issues 147 1.6 Lusso 2002 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 11-10-13 Thread Starter
Status: -
Join Date: Oct 2013
Location: United Kingdom
County: Warwickshire
Posts: 1
Not Happy radio issues 147 1.6 Lusso 2002

Hi Guys,
I am new to Alfas a and this site I have just purchased a 147 Lusso but I am having problems with the radio/CD .The head unit is stuck on one channel and no buttons work on the unit or the starring wheel.
I did try to press buttons 'turn the key and put my foot on the clutch or some silly sequence like that and by a miricle I had a working like a treat then a few days later showing off and it went out of sync again with the controls.
Any ideas I can't use the radio or CD by the head unit or the starring controls.
Do you think I need a new unit even though I had the unit working fully before,
Thanks for looking at my post waiting for solutions.
Samson6104 is offline  
Sponsored Links
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Moved to tech lounge
BigFoot is offline  
Status: Thinking about giulia veloce
Club Member
Membro Premio
jwq's Avatar
Club Member Number: 857
Join Date: Jan 2005
Location: The Netherlands
County: Zuid Holland
Posts: 4,102
Images: 16
Maybe it's locked, and you first need to enter the radio security code ?
jwq is online now  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , 2002 , alfa 147s on 16 , issues , lusso , radio , radio or cassette , radio or headunit

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome