I've developed a whirring noise from the back! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
I've developed a whirring noise from the back!

My 156 has developed a gentle whirring noise from the rear wheels. I am guessing wheel bearings. At 72k I'm guessing they will be pretty mullered by now. ANy other possible causes?

If it is the rear wheel bearings,Is it an easy fix/replace, might be a good time to do back discs and pads?

Sponsored Links
Status: -
AO Silver Member
glenda's Avatar
Join Date: Jul 2005
Location: Co.Tyrone, N Ireland
Posts: 1,624
Images: 6

Member car:

145 1.8 T-Spark

Re: I've developed a whirring noise from the back!

Hi Andy
I've had a problem with a noise from the rear of my car too,although my 145 only has about 55 K miles on it.

Get the tyres checked out too.

I've got Bridgestones on my car and the tyre is wearing unevenly along the pattern of the tread, so it may be something else to look out for as well as the bearings. I went to the expense of getting a wheel bearing changed and it turned out to be ok

Check out the thread titles "Rhythmic thumping noise" in the 145 section.

Hope this helps
glenda is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

back , developed , noise , whirring

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome