Remote key (s) not disarming or opening?? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Hmmm Remote key (s) not disarming or opening??

Any ideas here would be really helpful....

....went to unlock the car this morning and no response from the car at all, not even the boot release..( the keyfob lit up and they both have new batteries in them ) tried several time but to no avail, so I went and got the spare key and 3/4 button presses later it opened as it should.

I went about the jobs I needed to do locking and unlocking with no dramas, then when I go home it locked and wouldn't open with either key...after ages of random buttom presses it opened and now I have just used the key to manually lock the doors, all central locking is working fine, all batteries are new and the cars is in good order!

It's like the car just doesn't respond to the keys signal ??

Over to you?!
Sponsored Links
Status: - Update
Posts: n/a
Status: I'm too old for a midlife crisis
AO Member
CT1's Avatar
Join Date: Sep 2008
Location: United Kingdom
County: Essex
Posts: 365

Member car:


It is quite common for the micro switches to fail on these fobs. Do a search for Alfa Romeo key fobs on eBay there's a guy on there does them for 19 I've had both mine done no probs since.
CT1 is offline  
Status: Fixing all your keys !!
AO Silver Member
Chris's Avatar
Join Date: Mar 2001
Location: United Kingdom
County: Tyne and Wear
Posts: 3,806
Images: 2

Member car:

a very dirty car

That's me

But to be fair if the light is coming on its a good start but if its a 3-button key then the earlier ones (the ones with a solid plastic case and not a rubber patch over the buttons) suffer from poor range as well as tons of other problems. If the range is generally ok though then the key is going to be repairable.
If the range is rubbish then a newer version of circuit can do the trick but that's a bit more pricey.
The later ones also have problems but not quite as many and usually the light won't flash when they go wrong.

If you want a repair on one of the keys you can find me here:
Zaksystems Key Repair
Its a repair service with full refund it it doesn't need fixing or can't be fixed so nothing to lose really

But even before all of that, try disconnecting the car battery for 10 minutes. That sorts out lots of niggles and gives you a good starting point.
Chris is offline  
Status: - Update
Posts: n/a
Thanks for the input, but both fobs seem to be working fine, both light up on all button presses...the batteries are new and I was stood right beside the car, its just a lottery if the car will respond to the remote!, I can see the question of a fault with the key, but we are talking about both keys with the same sporadic response from the car.

What receives the signal inside the car, is it possible to be an antenna issue?

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

disarming , key , opening , remote

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome