Help.. My 147 is dead following a cambelt breaking - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 29-09-13 Thread Starter
Status: Devastated
Join Date: Mar 2012
Location: United Kingdom
County: Essex
Posts: 2
Help.. My 147 is dead following a cambelt breaking

The cambelt has broke on my 147, and i'm now thinking it's going to cost me a fortune to get repaired.

Is it worth getting it repaired and could anyone suggest a decent garage to take it to?
Stef147 is offline  
Sponsored Links
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,069
Sort of depends on what age and condition your car is in, and how long you were thinking of keeping it.

A replacement head, with gaskets and new belt and tensioners, will probably be about 300 - 350 plus labour. You can get a complete replacement engine for the same or less, again plus fitting. If rebuilding, it really is also worth spending another 50 or so to change the big-end bearings while you are at it.....

As it is you'd probably get just over scrap money for the car...say 200. So have a look around and see what you can get for 750 or so - it might be cheaper and easier to go down that route, but if otherwise your car is in good nick with a long MOT, it might be better to spend the money repairing it.

I have a 1.6 147 engine that I rebuilt, only for the car to be vandalised....but I'm a long way away from you....

AROC Vice-Chairman and Lancashire Section Secretary

Alfa organ donor to the gentry......
rgwm is offline  
Status: -
AO Member
driver33p4's Avatar
Join Date: Jan 2004
Location: United Kingdom
County: Western Isles
Posts: 950
Images: 16

Member car:

Alfa Red GT Q2

I am in the process of clearing out my garage of twinny parts and could supply you with a timing belt set and either a rebuilt head with a new water pump (200 for the lot) or a second hand head (150). I would throw in a set of new head bolts and a set of big end bearings for 200 (I might even have a head gasket).

Plus postage of course
driver33p4 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , breaking , cambelt , dead

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome