Snapped handbrake? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 27-09-13 Thread Starter
Status: Formerly 166, GT, 147,155,33
AO Silver Member
CCOVICH's Avatar
Join Date: Aug 2005
Location: Ireland
County: Kildare
Posts: 2,419
Images: 2

Member car:

159 2.4 JTDm

Snapped handbrake?

Stopped in traffic on a ramp this evening, pulled handbrake, sounded like something snapped. Handbrake still engages, but much much less tight than previously.

Am I right in saying that there are two cables and one of mine has probably snapped?
CCOVICH is offline  
Sponsored Links
Status: Tin worm attack ... ARGHH!
AO Gold Member
gazza82's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,290
Images: 12
Yes. Been there ... Done that ... Change both as the other one will go soon probably. Got mine from but depends how long you can wait. Leave it in gear.
gazza82 is offline  
Status: -
AO Silver Member
t3yls's Avatar
Join Date: Aug 2007
Location: Manchester
Posts: 2,810
Images: 4

Member car:

Alfa GT Jtdm

Yeh had that too. A new cable is all that was needed -for the garage to fit, of course!
t3yls is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

handbrake , snapped

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome