Car Pulling To The Left . . - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: 110,300 and Warm
AO Member
James76's Avatar
Join Date: Mar 2005
Location: United Kingdom
County: Scottish Borders
Posts: 607
Images: 6
Re: Car Pulling To The Left . .

Just to add my tuppence worth, if there is anything weird going on the suspension it is worth getting it aligned on an alignment dyno. These things are v sensitive. I know that Kwik Fit would not touch the 155, their instructions were simply "refer to specialist" and the 155 was nowhere near as complex in suspension set up as the 156.

I am lucky in that i have a very good specialist near to hand who will charge an hour's labour for a full alignment - and yes you can tell the difference from a simple laser alignment.

Find one! - as all suspension settings including ride height will be checked.

We have no plan, therefore nothing can go wrong (much)

And i Have finally put piccies of the silver one on!!
James76 is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Aug 2003
Location: Bristol
Posts: 5,002
Re: Car Pulling To The Left . .

Might be worth checking that any previous alignment correction has been done equally on both track rods. I had an Astra where the steering wheel was on the wonk when the car was driving straight, it was because all the correction was done on one adjuster (the Vauxhall adjusters tend to seize). This meant that the Ackermann angles were different left to right causing it to pull
mave is offline  
(Post Link) post #28 of 33 Old 17-05-06 Thread Starter
Status: is fed up!!
AO Member
Join Date: Jun 2005
Location: United Kingdom
County: North Yorkshire
Posts: 452
Re: Car Pulling To The Left . .

Well I went back today and sure enough the alignment was out. Luckilly the manager wasn't about so i had a word with one of the lads and he simply asked me to put it on the ramp and away we went.
I asked him to check the rear allignment as well this time which he did and it was fine.
The front however was out by quite a bit. This time they spent time centring the steering wheel and adjustim from both sides.
I have a printout this time also which I am hoping to scan in and attach so that people that actually understand them can have a look.
The lad even tied up my undertray for me with zip ties
But once I got in and drove away I noticed that the car is still pulling to the left and i know he did it all ok as I was watching him and being a pain asking loads of questions.

Also I noticed that it appears to pull more when I am not on the power - it does it less if I accelerate (still does it just not as bad).
Do you think there is something more serious than tracking wrong?
BigRed is offline  
Status: -
Join Date: Feb 2007
Posts: 4

Member car:


Re: Car Pulling To The Left . .

Did you fix the problem with the steering pulling to the left? I have same problem but pulling to the right, just bought the car and still have to get it checked out. cheers
blackie147 is offline  
(Post Link) post #30 of 33 Old 16-02-07 Thread Starter
Status: is fed up!!
AO Member
Join Date: Jun 2005
Location: United Kingdom
County: North Yorkshire
Posts: 452
Re: Car Pulling To The Left . .

Hi Blackie147 - no it is still doing it after all this time. I had another 2 new tyres fitted last week at the front. This time however I have also now got a droning noise that gets louder as I make a left turn. i think that its safe to say its a wheel bearing thats gone.
I am convinced however that what ever was wrong before has caused the wheel bearing to go. The garage that fitted the tyres did a quick check of the steering/suspension system at the front as my car has also developed a "squeek" on large bumps (speed bumps mainly). They informed me that there is play on the off side upper wishbone.
So it could have been a wishbone problem all along but has only started to squeek in this cold weather and also with all the road salt drying things out.
I have the car booked in on Sat to be checked by Justin at Bluebell Motot Company ni Newton Aycliffe. I will post back when I find out whats what.
BigRed is offline  
Status: -
AO Member
Mattyc's Avatar
Join Date: Jan 2005
Location: Hull
Posts: 989
Images: 2

Member car:

159 1.9 jtdm

Did you resolve this big red? I have the same problem, have been advised its a worn lower ball joint with excess play. Thanks.
Mattyc is offline  
Status: "My P
AO Member
EnglandBoy's Avatar
Join Date: Jan 2011
Location: United Kingdom
County: North Yorkshire
Posts: 241
Originally Posted by urban View Post
You probably have to align the steering. Just that and then she'll be fine again

Note: Here in Portugal we say align the steering, but I don't know how you british say that. It's when you go to a garage and they stick some things on your tires and then verify if they're all aligned (with a machine).
EnglandBoy is offline  
Status: -
AO Member
virmanih's Avatar
Join Date: Jun 2010
Location: United Kingdom
County: Merthyr Tydfil
Posts: 501
I got a 4 wheel allignment done in January, then I was told the lower wishbone was knackered in Feb during the MOT. Changed the wishbone and the 2 tyres on the front and got it alligned again. Then got the 2 upper wishbones and drop links changed as the suspension was getting on my nerves, also got the tracking done for front as the rear should be fine. Now the car pulls towards left and it has gone worse in last few weeks. The front passenger side tyre is worn on the inside.Also I noticed that it appears to pull more when I am not on the power - it does it less if I accelerate (still does it just not as bad). The tyres were only changed in Feb and I would like to get the problem solved before I shell out another 100 quid, any help and suggestions will be greatly appreciated. Thanks

You never really learn to swear until you learn to drive.

Anyone driving slower than you is an idiot, and anyone going faster than you is a maniac.
virmanih is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

car , left , pulling

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome