Post head gasket running in - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 23-09-13 Thread Starter
Status: Brrrrrummmm
AO Member
Join Date: Oct 2006
Location: United Kingdom
County: Hampshire
Posts: 208

Member car:

147 GTA

Post head gasket running in

Ive just completed a head gasket change on the GTA and am ready for restarting her.

Any advice on running in or other tips before I fire it up?

Ive got the engine filled with 10w-40 which i'll run on for a couple of weeks before changing the filter and refilling with 10w-60.

Cheers James
jimbo147 is offline  
Sponsored Links
Status: I am also Keith......
AO Member
kam325i's Avatar
Join Date: Sep 2012
Location: United Kingdom
County: Shropshire
Posts: 565
Some may say to turn the engine over a few times with the spark plugs removed, just to make sure oil pressure builds up......
kam325i is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

gasket , head , post , running

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome