Looking for some reassurance - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 19-03-06 Thread Starter
Status: Breraless :(
AO Platinum Member
Squadrone Rosso's Avatar
Join Date: Aug 2005
Location: United Kingdom
County: Neath Port Talbot
Posts: 29,893
Images: 45
Help Looking for some reassurance


In an attempt to fix the poor radio reception on my '04 156, it's going into the main dealers to have the aerial, aerial base and all the aerial wiring replaced in line with a service news bulletin

But I'm worried It's a 2 day headlining out job & presumably the roof mounted curtain airbags will have to come out too

My main fear is that it'll rattle or squeak afterwards as it's as quiet as a mouse at the mo or they'll break things like the grab handles or it will sag / not fit properly once completed!

To date, they've replaced the stumpy mast with a longer one, replaced the signal amplifier and replace the entire headunit. The mast made a bit of a difference but when they ran the VIN number the S/N bulletin was flagged

Has anyone out there had the same or similar job done and if so, was the result OK? I've told the dealers of my worries but they assure me it will be fine!



Daily Driver FIAT Panda Cross Twinair Stunning Giulia 115 Spider Series 4 fine weather toy

Wife's Daily Brilliant Toyota GT86

AROC South Wales Section Secretary

Last edited by Squadrone Rosso; 20-03-06 at 07:00.
Squadrone Rosso is offline  
Sponsored Links
Status: -
AO Member
Join Date: Feb 2006
Posts: 445
Re: Looking for some reassurance

hi m8, have you tried adding a amplified ariel adapter. all it does is fit in between your original ariel connection on the back of the headunit and takes a live feed from the wiring. Reletivly easy to install and could solve the problem, worth a try (you can buy these adapters from any halfords store, at around 12)
superturismo is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome