Electric Windows - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 20-02-06 Thread Starter
Status: -
Join Date: Feb 2006
Location: Swindon
Posts: 1

Member car:

Alfa Romeo 156

Electric Windows


I've got a problem with my n/s rear passenger window. it works sometimes, and not other times (mostly not tho!!).

Its not the switch, because I've tried it on another door.. Does anyone have any other ideas?

spooky23 is offline  
Sponsored Links
Status: Just taken delivery of a pair of Giuliettas
AO Member
Join Date: Nov 2004
Location: United Kingdom
County: West Sussex
Posts: 185
Re: Electric Windows

I've just found my n/s rear window is very slow. All others are fine, and its not the switch, coz the drivers door switch and the actual door switch give the same result. To begin with, I thought it was just sticking, but it seems more like the motor is the problem. 2004 sportwagon, by the way.
ee61re is offline  
Status: My 159 is a bird poo magnet
AO Member
Irish147's Avatar
Join Date: Nov 2005
Location: Ireland
County: Limerick
Posts: 387
Images: 1

Member car:

159 1.8 Turismo

Re: Electric Windows

Try some silicon spray on the rubbers that surround the window...helps a lot...just don't go overboard.

Irish147 is offline  
Status: -
AO Member
Robin's Avatar
Join Date: Feb 2006
Location: Edinburgh
Posts: 105
Images: 12
Re: Electric Windows

Could there be dirt in the connector that goes from the cabin to the door? Try wiggling the flexible connection while you hold the button down. The fact that it goes up perfectly (and without any horrible noises?) sometimes and not others suggests that the actual mechanism is fine, perhaps some dirt in an electrical contact within the door? Not sure how big a job taking the door card off is?

My off-side rear window won't go up if you hold down the button, it goes up about and inch then stops, you have to keep flicking it on-off-on-off until it's all the way up! Same from switch in front and back.
Robin is offline  
Status: -
AO Member
BUFFY FAN's Avatar
Join Date: Sep 2005
Location: Huddersfield
Posts: 22
Re: Electric Windows

Hi there. I find the windows on my 147 are really slow and sometimes stop, meaning I have to hold down the switch and use my other hand to push the window back up. I've noticed it does it when it's a really cold day so maybe the motors don't like the cold?
BUFFY FAN is offline  
Status: -
AO Member
Join Date: Jan 2003
Location: North Dorset
County: Dorset
Posts: 22

Member car:

159 2.0 JTDm SW

Help Re: Electric Windows

I'm getting a similar problem, but now the window pops out from the back of the frame too! To make matters worse, I cannot get it to stay in now!
The Pasty is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

electric , windows

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome