high idle revs and low temp even after thermo change - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 10-09-13 Thread Starter
Status: Loving the Alfa Wave!
AO Member
Alfafrolic's Avatar
Join Date: Jan 2012
Location: United Kingdom
County: Merseyside
Posts: 139
Images: 2

Member car:

156 Sportswagon

Hmmm high idle revs and low temp even after thermo change

Hi Guys,
Car was achieving really poor MPG and people kindly gave instuctrion on thermo change.
Went from 55 to just over 70 on the dial, but never sits at 88???
does rise to 90 and fan kicks in when stationary, but why on normal 40 min drive, does it not make 88???
The car is idling at 1000, if i remove MAF engine light comes on but idle speed drops to orange line most of the time, but occasionally nearlry drops out. did throttle reset after putting back maf and light has gone, but again idling high??guess that the maf is working
Any clues to what my problem is... Oh think variator is gone as it rattles terribly but this would be poor fuel related, but not fast idle?
Alfafrolic is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

change , high , idle , low , revs , temp , thermo

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome