Selespeed problems 156 2001 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 10-09-13 Thread Starter
Status: -
Join Date: Aug 2008
Posts: 3
Madness Selespeed problems 156 2001

I have recently been encountering problems with my gearbox! It has been to an electrician and mangoletsi and no faults have been found on the diagnostics! It is getting expensive now and nobody can help I wondered if anyone else had the same probs? When it gets warm the gears drop out and jump from 1 to 3 to 4 to 2 and is juddery when trying to change like a flat spot also oil is being pushed out of the reservoir and I've been told it may be the accumulator ball but not sure! Mangoletsi said they could strip it for 2000 and tell me what's wrong! I said no thanks to that! Any help is appreciated guys
gar139 is offline  
Sponsored Links
Status: MOT Passed
Club Member
Membro Premio
baxter2308's Avatar
Club Member Number: 2209
Join Date: Feb 2013
Location: United Kingdom
County: North Yorkshire
Posts: 856

Member car:

147 Sport Q2

Have a look at these threads.

It may be of help to you. A number of members on AO have commented that with the money they spend on Selespeed diagnostics, you may wish to consider investing in Alfadiag or Fiat ECU scan diagnostic software for use with an OBD cable. You might not have any codes now but people have said it's a good investment for keeping your Selespeed in good working order. With a bit of luck your car won't be suffering problems with the actuator.

Hope you get it sorted.

147 Sport Q2: Autolusso Remap + Swirl Flap & EGR Delete, Mocal Oil Cooler Kit, JTD Performance FMIC Kit + High Flow Elbow, Wizard Downpipe, PF Pads + 5.1 Fluid, Autolusso Braided Brake Lines, MTech Short-Shifter, Autolusso Silicone Turbo-to-MAF Hose, Refurbed Q2's + Some to add later.
baxter2308 is offline  
Status: Gold Member
AO Gold Member
rarebear's Avatar
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,021
check out Youtube rarebear14 for a demo on my own 156 selespeed with Alfadiag
rarebear is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 2001 , problems , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome