156 V6 electrical problem - Help Needed please - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 08-02-06 Thread Starter
Status: -
AO Member
Join Date: Nov 2005
Posts: 10

Member car:

not a 156 yet!

156 V6 electrical problem - Help Needed please

I hope that some body will be able to help, I have posted in other sections too so apologies if you see this post everywhere.
I have a problem that started yesterday and all these electricals failed at the same time, just after i started to drive off. The car is a 1999 T V6.

All Electric windows
Electric Mirrors
Window Wipers
Indicators (but hazards work)
Climate control system

I have checked all the fuses and they all seem fine. Any suggestions would be helpful...

byron aldous is offline  
Sponsored Links
Status: -
AO Member
NiTRoGuY's Avatar
Join Date: Jul 2003
Location: Denmark
Posts: 321

Member car:

Not an Alfa...

Re: 156 V6 electrical problem - Help Needed please

Try wiggeling with the plugs on the rear of the fuseboxes, all the functions you mention are to my recollection on the main fuse box that is visible under the cover. There is another one further up behind the dash - try giving that a wiggle too.
NiTRoGuY is offline  
Status: -
AO Member
Redd's Avatar
Join Date: Jan 2004
Location: Malaysia
Posts: 472

Member car:

Alfa 156 2.5 V6

Re: 156 V6 electrical problem - Help Needed please

all those items are controlled by the "body computer" (that's what my mech calls it anyway), so that might be the culprit.

ive also had the same failure on mine and it turned out to be a fuse. just remove and reseat all the fuses and wiggle the connectors behind the fuseboxes. there are two, one easily seen and another above that one.

Redd is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , electrical , needed , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome