156 indicator issue - advice sought - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 03-02-06 Thread Starter
Status: -
AO Silver Member
jwyatt's Avatar
Join Date: Mar 2005
Location: Winchester UK
Posts: 1,236
Images: 30
156 indicator issue - advice sought

As per previous posts my car (2005 GTA SW) had it's indicators stop working briefly a couple of times, then they stopped altogether. 3 separate whole days in the dealer and now 3 consecutive ones have seen them still without the faintest idea what's up, besides the advice from Alfa technical that the new parts they tried must have been faulty. This seems unlikely as the rain sensor also broke (months before the indicators) and apparently they can't fix this either and think the replacement parts were faulty here too - it seems an unlikely coincidence.

Does anyone know of any other 156 (post 2002 facelift) models with this issue? Does anyone have any alfa mechanic friends in dealers or specialists they could ask? I'm going to try to keep the courtesy car (a 75bhp pug 1007!) until it's fixed but if the replacement replacement parts don't work I think I'll move it back to my other "local" dealer. I'm thinking the current lot can't be very good at isolating electrical issues, and I know they were struggling with the wiring diagram the first time it was in.
jwyatt is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , advice , indicator , issue , sought

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome