Vibration - steering column 147 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 20-01-06 Thread Starter
Status: -
emo-g's Avatar
Join Date: Oct 2005
Posts: 7
Vibration - steering column 147

3-4 weeks ago I started to hear a vibration noise in and around the steering column area. It's got progessivly worse to the point where it's driving me insane. It happens a low speeds, 30 - 40mph, almost constantly. I can also recreate it whilst stationery by hitting the accelerator hard and letting it return to idle. It sounds metalic, like something is just buzzing off something under the steering cowling.

Iv'e read lots on the site rearding vibrations but can't find a similar one.

I took it to Alfa yesterday, took a spin with a technician and recreated it for him. They removed the steering cowling and fuse cover, tighened all bolts and found a loose bracket. Lubricated everything up etc and tested it several times, at the cost of 77.

As soon as I took it home, exactly the same noise, no different. In fact they made things worse by overtightening something around the steering column as it makes a rubbing sound when doing a full lock.

Anyway, it's going back again in the morning. Hopefully they can fix it second time around.

Anyone out there had a similar vibration problem?

emo-g is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , column , steering , vibration

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome