New owner - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 29-08-13 Thread Starter
Status: -
AO Member
Join Date: Jul 2013
Location: United Kingdom
County: Somerset
Posts: 26

Member car:

alfa 2.0 gt 2006

Help New owner

Now been the owner of a 2006 2.0 GT JTS for 5 weeks i must say it is the best looking car i have possibly owned but in that few weeks i am becoming paranoid that little red box with all the warnings
First one said E M S Failure that was a lamba sensor fixed by local garage £180 paid by dealer

Next one my wife was driving and she said the EMSF warning came on followed by a symbol that looked like a watering can rose it went out and aint come on since all water levels are ok including screen bottle any clues?

3rd one windows a mind of there own i did try the advise given on my earlier thread that has not worked also i tried the reset in the manual of holding down for 3 secs in the up and down position.

Also i have noticed when driving in town and i hold it gently on the throttle it is looking for more if i change down from third to second it seem to be revving to much it maybe me as my previous car was a Freelander and i could put that one in second and i would crawl along without touching the throttle having said all that when i really drive the car the response is unbelievable i have also owned BMW and AUDI if not comparable better.

I am booked in to have cam-belts,water-pump etc next week by an ex Alfa dealer i will ask if they have any ideas but in the meantime if any one can give me help would be appreciated.
It is very helpful to have a forum like this but had i read it before i bought the Alfa? maybe the looks would have still made me buy it i certainly hope i don't get as many expensive problems that other members appear to have had.Meatman
meatman is offline  
Sponsored Links
Status: The last of the 156 Interceptors...
AO Member
AutobotVanguard's Avatar
Join Date: Jun 2011
Location: United Kingdom
County: Cheshire
Posts: 982
Images: 348
Firstly, congratulations on the new member of the family. Bear it in mind that this is a place dedicated to problems so in many ways it is not reflective of general ownership foibles. There are a number of issues which will punctuate ownership like with all cars and this is the place to learn about them.

EMSF warning light is not familiar to me, but if your wife drove with the handbrake engaged, it will fool the ECU into thinking that the oil pressure is low hence the oil can wanting light. There is no light for coolant fluids to my knowledge other than the temperature gage.

The timing is ten seconds up and down for the window switches and try disconnecting the battery for 45 mins if this fails. Search the forum, there are loads of posts on this.

The engine is a bit like a Honda v-tech and the power comes from the changing cam profiles. If you wanted to trundle around in third then you should have bought a JTD. The petrol isn't set up with torque in mind, though a remap might help this a bit.

Find a good independent Alfa specialist and you will save a fortune. I used a crap garage and they broke my car.


Alfa 156 M-Jet 16v Sport
Rhoddy Harvey Bailey revalved Bilsten B8 damping kit
Eibach Pro Kit
15mm wheel spacers
Wiechers strut brace
Air freshener
AutobotVanguard is offline  
(Post Link) post #3 of 4 Old 29-08-13 Thread Starter
Status: -
AO Member
Join Date: Jul 2013
Location: United Kingdom
County: Somerset
Posts: 26

Member car:

alfa 2.0 gt 2006

Thank you for your reply i take note of para 1 i agree with you, with ref to the light no she did not have the handbrake on and the symbol that came up was not the same as an oil can it was as i described it was similar to the one on the top of the windscreen washer bottle and it came up in the screen that displays the date and radio name.
Ihear what you say with with regards driving but i am talking about when i am in town and can only do 20-30 mph on the open road excellent
Again thanks for your reply
meatman is offline  
Status: Lowered!!
AO Rosso Alfa Member
Durty dog's Avatar
Join Date: Feb 2009
Location: Northampton
County: Northamptonshire
Posts: 73,506
Images: 18
Hi and welcome
I see you have already posted in the southwest, someone on there might be able to point you towards a good indie.
Durty dog is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome