Help! Motion Control System Failure - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 21-08-13 Thread Starter
Status: -
AO Member
Daytona's Avatar
Join Date: Jun 2006
Location: United Kingdom
County: Greater London
Posts: 744
Help! Motion Control System Failure

Hi All,

Two weeks ago I got the MSCF failure come up in the display, and had reduced performance.
The car seemed to drive fine but wouldn't rev past 3.2k revs, at which point it felt like it had hit a limiter.

It then went off and normal performance came back.

Now it has come on again - with same symptoms.

No clue what caused this, but I need my car for work so would like to get it sorted ASAP!

ANy ideas guys & gals?


Daytona is offline  
Sponsored Links
Status: Paint it black
AO Member
INS147's Avatar
Join Date: Oct 2010
Location: United Kingdom
County: Highlands
Posts: 551
Images: 4

Member car:


Have you had the ECU checked for stored error codes?
You might also read through this
INS147 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

control , failure , motion , system

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome