Oxygen Sensors. I Need wiering map from ECU to Lambdas on 156 JTS 2003, MK2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 19-08-13 Thread Starter
Status: -
Join Date: Jun 2013
Location: Iceland
County: Hofuoborgarsvaeoi
Posts: 1
Not Happy Oxygen Sensors. I Need wiering map from ECU to Lambdas on 156 JTS 2003, MK2

Good morning, evening or vhatewer
Some ass has been mending Lambdas in my car and cut out the plugs and connected the wires from ECU to the Lambdas, likely randomly and wrong so the car keeps flashing engine light and the OBD2 reader identify 2 Lambdas as the problem.
It is useless to change the Lambdas for new or turning off the lights with the OBD2 reader, it comes back and same error.
What I need is some "diagram" or drawing, how to connect those wires from ECU to Lambda without a plug.
I already got 1/2 of the story from Cambiari but the rest, the Lambdas wiring diagram and where to place those numbers given in the plug it self, the could not provide that.
Attached picture 1: Alfa 156 wiring
And this is how it is mended now.
Attached picture 2 and 3: Lambda l & R
My car is Alfa Romeo 156 JTS, MK2 2003,
VIN: ZAR932000*00220212
Engine: 937A1000
Version: 932AXA00, 52
Spraes: 0514318
There is additional ID on the right side front that reads 9418475 1, it is also as a barcode
There are 4 lambdas in my car, 2 before and 2 after cat. One on each side, before and after catalysator.
If anyone ewer ran ibnto something of this sort of problem and knows anything about how to mend at low cost, please.
Or pictures of the plugs and how and where the wires are connected in them, the organisation of the numbers in then, please prowide it.
So I can onnect it correctly togather. The car has gone about 130000 km and likely there are new universal lambdas in it, all display right color wire that I best can see but those do not match the colors on the wires from ECU becose there is supposed to be a plug between those to match, and on the pre cat Lambdas there are 6 wires from ECU but 5 wire Lambdas that I came close to identify and as you can see on those pictures I took, there is a loose end. What to do with that one when connected correctly? Are there any special plugs in this car?
Hope somone can help
Attached Images
File Type: png Alfa 156 Lambda wiring (2).png (19.7 KB, 20 views)
File Type: jpg Lambda L F-B.jpg (95.8 KB, 16 views)
File Type: jpg Lambda R F-B.jpg (83.9 KB, 11 views)

Last edited by Pablo Escobar; 20-08-13 at 00:10.
Pablo Escobar is offline  
Sponsored Links
Status: bring back tapatalk
AO Silver Member
trashbat's Avatar
Join Date: Jun 2010
Location: United Kingdom
County: Hampshire
Posts: 2,518
Have you considered just buying a new wiring loom? Probably about 100EUR, and a pain to fit, but possibly easier than trying to correct someone else's work.
trashbat is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 2003 , ecu , jts , lambdas , map , mk2 , oxygen , sensors , wiering

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome