A stupid clip question - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 17-08-13 Thread Starter
Status: -
AO Member
Join Date: Aug 2009
Location: Slovenia
County: -
Posts: 436

Member car:

AR GT 3.2V6

A stupid clip question

Which is.. how to undo and redo this clip? Havent really had the courage to mess with it in case I would not be able to put it back on...
Attached Images
File Type: jpg wp000612.jpg (44.8 KB, 10 views)
File Type: jpg wp000613.jpg (42.8 KB, 7 views)
Binji is offline  
Sponsored Links
Status: Freezing!
AO Silver Member
Rockhopper's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Nottinghamshire
Posts: 4,864
Destroy it to get it off and replace with a jubilee clip. I think there is a special tool you can buy though.
Rockhopper is offline  
Status: Alfa drivable again! Yippee!
AO Member
Join Date: Jul 2011
Location: United Kingdom
County: Somerset
Posts: 353

Member car:

156 2.4 jtd x2

Hello chaps,

Not often the Rockster is wrong...but on this occasion...that looks very similar to those confounded original water pipe clips that Alfa insisted on using (to which my esteemed friend refers) which you will indeed need to destroy to remove...BUT this looks to me like the original jubilee clips holding on the hoses to/from the intercooler, which will come undone using either 6 or 7mm socket - and be reusable!

Hope that helps
The Captain
captainboogaloo is offline  
Status: - Update
Posts: n/a
I believe both are right. The curved bit looks like a sprung shield. The clip is screwed up most of the way, then the clip is added to act like a spring clic R clip.

To remove, pull the C shaped shield off, then it should unscrew, but will probably be jammed and need hacksawing off.

Either way, wide, proper jubilee clips are better.

[color=gray]Sent from AutoGuide.com Free App[/color]
Status: -
AO Member
Join Date: Mar 2012
Location: United Kingdom
County: Kent
Posts: 73
7mm socket will undo it done mine today
bigeyerex is offline  
Status: Alfa fanatic
AO Member
j300sjl's Avatar
Join Date: May 2009
Location: United Kingdom
County: -
Posts: 401
7mm yes - did one myself too
j300sjl is offline  
Status: I ask a lot of questions!
AO Member
Join Date: Apr 2013
Location: United Kingdom
County: West Yorkshire
Posts: 439

Member car:

alfa gt 2.0 jts

My car has this too....I was looking at it all confused like that isn't a jubilee clip lol
piedthepiper is offline  
(Post Link) post #8 of 8 Old 17-08-13 Thread Starter
Status: -
AO Member
Join Date: Aug 2009
Location: Slovenia
County: -
Posts: 436

Member car:

AR GT 3.2V6

Thanks all. I was right.. it was a stupid question Seems pretty obvious now that Im looking at the pictures.

Its a clip on the upper hose which goes into the inlet manifold. Will have to replace it once the new one arrives. I do think I will buy a couple of clips before I tackle it just in case
Binji is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

clip , question , stupid

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome