Mother control system failure - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 11-08-13 Thread Starter
Status: -
Join Date: Jan 2013
Location: United Kingdom
County: Down
Posts: 4
Mother control system failure

Hey guys had this warning light come couple of times last yr but would then disappear with no problems arising. However in past wk whilst driving, a couple of times while slowing to stop then trying to accelerate I lose all power and car conks out. Try to restart but won't straight away.

1st time it happened it took bout 5-10min before it would restart but last nite took 30min before restarting.

Does anyone have any ideas of problem before I call garage in morning?
Andyc147 is offline  
Sponsored Links
Status: DEFCON5
AO Gold Member
1of1's Avatar
Join Date: Oct 2010
Location: Sao Tome and Principe
County: Principe
Posts: 11,605
Images: 7
Crank sensor?
1of1 is offline  
Status: -
AO Silver Member
SLM3CFC's Avatar
Join Date: Sep 2008
Location: United Kingdom
County: Greater London
Posts: 2,363
Sounds about right. Especially the waiting for a while for it to be ok again
SLM3CFC is offline  
Status: -
AO Member
Join Date: Jul 2013
County: -
Posts: 31

Member car:


Had similar on a Lancia with the coolant temp sensor. Would start fine in certain temp ranges, and do nothing at other temps. Replacement took 5 mins and cured it.
ctu is offline  
Status: Freezing!
AO Silver Member
Rockhopper's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Nottinghamshire
Posts: 4,864
Motor control system failure could be any one of a multitude of things - the only way to be sure is to get the fault codes read. In your case is does sound like a classic crank sensor failure (RPM sensor).
Rockhopper is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

control , failure , mother , system

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome