kangarooing 147jtd - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 06-08-13 Thread Starter
Status: -
Join Date: Jul 2013
County: -
Posts: 1

Member car:


kangarooing 147jtd

Hi All
My wifes 147JTD has been losing power and making a whooshing sound for a while, it also displaying motor control system failure.
Looking around the internet it had all the usual symptoms, clouds of black smoke and sluggish response. More recently it has started “kangarooing” when setting off / going up hills and recently started to stall from time to time
We took it into the local chap and he found the upper and lower turbo pipes had holes and they have been replaced. We had hoped it was the end of it.
Now there is no black smoke or whoosh but the “kangarooing” and warning light are still on
It’s a 2004 model and it`s been a great car expect for the dual mass flywheel which was replaced about 2 years ago.
It`s done 100,000 - is it time to get rid?
I didn’t want to have to replace it till next year really but I don’t want to keep spending money on a car we are getting rid of / might cost more than the value of the car
Any ideas what else could be causing the issues, its also very intermittent – one day its fine the next day bad
slappy is offline  
Sponsored Links
Status: - Update
Posts: n/a
Check turbo hoses for splits, 99% be this is a whoosh you heard.... inspect top and bottom hose carefully...

See veloce or autolusso for silicone replacements about £70 each.

2nd, if you've never done it look up mscf thread on here and look at link/details on how to clean egr and map sensor this cold easy cause power issues, when changing gear or drop clutch and back on does power sometimes settle?. All black soot due to hose split will have blocked egr and probably clogged up map (these will cause car to loose power and drop into limp mode etc - likely running issues your seeing now)

3rd check small bore hoses to vgt solenoid (top rear of rad) and replace with 3mm silicone (Few £) follow hose down to turbo and clean the arm on turbo vgt actuator then lubricate.

The hoses will be big issue then maybe egr / map (especially with the clouds of black smoke). Plenty of guides on here and very easy DIY jobs. After all that (do in order over a few weeks). Apart from hoses all free of costs. Once finished it will run like new.

If cleaning egr consider restrictor gaskets (rectangle one with 4 holes and diamond shape with 3) helps prevent egr clogging up again and should cost about £6.

Hope that helps


Last edited by mr-mac; 06-08-13 at 23:13.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147jtd , kangarooing

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome