Passenger Window no longer working on GT - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 29-07-13 Thread Starter
Status: -
AO Member
Oupa's Avatar
Join Date: Dec 2012
Location: South Africa
County: Western Cape
Posts: 27
Passenger Window no longer working on GT

Please Help!

A while ago I got into my car and the display kept saying that the passenger door was open. It then went bonkers and the window was dropping and raising(as if you are opening the door) and then it sorted it self out.

The next day the window went crazy again and all of a sudden nothing. I can no longer open and close my window, Plus it doesn't drop any more when you open the door.

Does anyone know how I can sort this out I have tried to do the reset(hold the switches in the various possitions for 10+ seconds) but that solved nothing.

Could it be a blown fuse or could it be something more expensive to fix.

Thanks in Advance:-)
Oupa is offline  
Sponsored Links
Status: - Update
Posts: n/a
Try disconecting the battery for 10 mins then reconnect try the reset again if nothing it is probably the door/window sensor .Did you check the fuses and relays .
have a quick look on the GTV bit on here they have a similar system not sure if its exactly the same but might give you a few ideas failing all else ok

Last edited by gibot123; 29-07-13 at 13:56.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

longer , passenger , window , working

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome