Clutch Slave Cylinder gone AWOL - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 31-10-05 Thread Starter
Status: -
AO Silver Member
Join Date: Jul 2004
Posts: 1,997
Not Happy Clutch Slave Cylinder gone AWOL

I'm really cheesed off. On holiday last week found myself stranded on a dodgy bit of road near Southwold with according to the local breakdown people was a knackered clutch slave cylinder. So the only option was to have the 147 towed back on the Sunday the last day of the hoiday to the garage from whence it was bought 11 months ago to have it repaired. Here's the cute bit. The Warranty ( which I read whilst waiting for the pick up) states the car has to be serviced every 6,000 miles! So the garage informed me that as I hadn't had it done then they would have to service the car before the warranty could take place at a "cost" of nearly 500 for the warranty work alone.
I've done nearly 13,000 miles since I've owned the car in just under a year. The 60,000 service will cost @ 350+
You kind of expect a problem with an older Alfa like my 75 but this 147 is beginning to be another black hole.....
Steve20 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

awol , clutch , cylinder , slave

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome