JTS @ 1500 Rpm - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 29-10-05 Thread Starter
Status: -
AO Member
Join Date: Sep 2005
Posts: 16

Member car:

156 JTS

JTS @ 1500 Rpm

My JTS has annoying niggling problems in the 850 - 1500 rpm range.
My understanding is that AR have implemented a down-scoped version of the Bosch MED7 lean-burn system. The features are -
Lean burn operates only from 1500 rpm to idle where the throttle opens fully and a 25:1 a/f ratio can be achieved. There are no high NOx issues and therefore no accumulator cat / controls. Also, the EGR is internal within the head.
Pickup from idle in 1st can be jerky but the really annoying issue is on over-run when 1500 rpm is reached. The system injects fuel and tries to hold the rpm steady for some 6 - 8 seconds. After that it goes to idle.
The car must be in motion for this to occur. Therfore the vehicle speed sensor is involved.
By the way. the car has a clean bill of health from the Examiner - Smart
If anyone has experienced similar issues I'd appreciate hearing from you.

Last edited by bafurco; 29-10-05 at 20:54. Reason: Typo
bafurco is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

1500 , jts , rpm

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome