Alfa 147 1.6 - erratic idle - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 26-07-13 Thread Starter
Status: -
Join Date: Jul 2011
Location: Portugal
County: Lisboa
Posts: 5
Alfa 147 1.6 - erratic idle


I have a 147 1.6 that has an erratic idle, the rpm don't stay in one place and the engine shakes.

It happened after i stalled the car. I was waiting in line with the first gear engaged and took the foot off the clutch. I just noticed the shaking after i got home.

I was in the mechanic and we checked:

- piston compression - 11 bar in all the pistons
- injectors checked - OK
- coils are OK as well
- MAF checked

No errors in the diagnostic software.

Everything is good with the engine, no loss of power, just the idle is erratic and the engine shakes a bit in idle.

Over 1100 rpm all is well.

The mechanic told me to buy a full set of spark plugs since he didn't have a new set to check.

Also told me that he wanted to check the variator assembly to rule it out, that because i stalled the car while it was engaged it could have taken the idle out of point.

Is this possible?
RavenOne is offline  
Sponsored Links
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
Joss's Avatar
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 18,898
Images: 14
The MAF can start to fail even though it's not thrown up an error. Check the values the engine is expecting and what is receiving from the MAF. The variator is mechanical and moves in the higher end of the rev range. Unless the car sounds like a tractor when you start it then it is ok and functioning. The 147 doesn't have an idle control valve like the other ts's so might want to look at the throttle body itself.
Joss is offline  
Status: wanted dead and alive!
AO Member
SchrodingersCat's Avatar
Join Date: Jan 2013
Location: United Kingdom
County: Norfolk
Posts: 450
It's worth checking the lambda sensor too.
SchrodingersCat is offline  
Status: faclifting a 156
AO Silver Member
biffa's Avatar
Join Date: Oct 2006
Location: United Kingdom
County: Lancashire
Posts: 3,199
Images: 9
I'd go lambda too. But try a reset first not sure if mulitECUscan allows you to do this in the free version though.
biffa is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , alfa , erratic , idle

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome