147 JTDm water pump - to change or not? - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
AO Gold Member
Join Date: Aug 2007
Posts: 7,040

Last edited by Spider95; 14-08-13 at 21:26.
Spider95 is offline  
Sponsored Links
Status: - Update
Posts: n/a
I plan to have a little look soon and at least check belt only running in middle and if any coolant evidence through bearing hole or anything so will report back then
Status: -
AO Silver Member
Join Date: Dec 2009
Location: United Kingdom
County: -
Posts: 1,171

Member car:

147 JTDM 16V

1.9 MJET 16V

Does anyone know why Alfa put an indicator mark on the camshaft pulley when it's not keyed to the cam itself ?

I'm doing the cambelt right now and the old belt has no timing indicator lines on it (Gates Powergrip belt, first replacement I think). I'm going to have to mark the old belt to the indicators on the cam and crank pulleys and transfer the marks to the new belt (or at least check they match the marks on the new belt). I can't use the cam pulley mark as is because I can't be sure it was set correctly to the marked belt indicators when the totally unmarked Gates belt was fitted.

Just interested to know if the belts fitted at the factory have the timing marks already indicated or is that just an after market addition ? I'm guessing they did come with markings because the new kit seems to be Alfa original (has markings) and there seems little point having the markings after market if you can't be certain the cam sprocket indicator mark was set correctly at the factory when the engine was first setup using the timing tools.
Alexie is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , change , jtdm , pump , water

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome