Turbo problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 22-07-13 Thread Starter
Status: -
AO Member
sergiock's Avatar
Join Date: Apr 2013
Location: South Africa
County: Gauteng
Posts: 23
Images: 6

Member car:

Alfa GT 1.9 JTDm

Turbo problems

Hi guys i am having a challenge with my gt turbo.took it to someone the last time but he says the turbo need to be replaced,but the car has a very fine boost its like theres something blocking the air.took it to another he says it cannot be the turbo cause the first signs on turbo is when the car starts taking oil and my oil levels show full when i start the car but i also didnt check manually by the dipstick.he says its probably its the air fitler thats blocked but if u go under the car you get some one to rev the car i can see the boost pipe is squeezing and the air is not flowing properly its like getting throttled everytime you boost the car and there is alot of oil on that pipe.anyone had this before??
sergiock is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

problems , turbo

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome