GT Xenon - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 18-07-13 Thread Starter
Status: -
AO Member
Join Date: May 2012
Location: Sweden
County: Västernorrland
Posts: 52
GT Xenon

Just changed my rightside Xenon unit because the old one died.
After replacing for a complete new unit I still get the message "right headlight failure" but it's fully functional now.

Do I have to clear codes at a workshop? asking because it's a long-long drive to a workshop.

Also I noticed that the self leveling is abit odd. When I start the car the left headlight turn/goes up, and the right headlight turn/goes down, and then they go back and meet in the middle and settles.
Is it suppose to be like this or did I do something wrong with the installation?
All other cars I'v seen both the headlights turn/goes up then down to settle
Alfisti89 is offline  
Sponsored Links
Status: - Update
Posts: n/a
Sounds like the body computer needs calibrating with the new headlight. You can do this using dealer diagnotics or Fiat ECU scan and a cable (or two).

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome