Clutch release bearing? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 15-07-13 Thread Starter
Status: Think! use your head and not your heart...Aaargh
AO Member
Join Date: Feb 2013
Location: United Kingdom
County: Essex
Posts: 30
Clutch release bearing?

Any insight is welcome....I notice that my clutch seems to make a funny rumbling crackling sound when clutch pedal is depressed especially close to biting point. It doesnt happened all the time but a bit often to be bothersome.

Is the clutch on my Alfa on its way out or is it a clutch release bearing problem?

Proo212 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jan 2013
Location: United Kingdom
County: South Ayrshire
Posts: 53
Hi It certainly sounds like mine which went duff shortly after.
In my case, the bearing was making a slight whine on overrun - which gradually got worse and the biting point raised over two days till I couldn't select any gears.
Turns out that the release bearing has two fork pockets - one of mine deformed then detached itself .

When you fit a new Clutch Assy make sure no one fits the thrust bearing to the pressure plate - as it will lock on - the bearing should be fitted to the drive and the forks located in the pocckets before the g/box is offered up to the engine.

Good Luck

Last edited by Wildfire; 16-07-13 at 21:00. Reason: shocking spelling!!
Wildfire is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

bearing , clutch , release

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome