Flashing Odmeter Display - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 21-09-05 Thread Starter
Status: -
AO Member
gazzaputt147's Avatar
Join Date: Apr 2005
Location: Bexley, Kent, UK
Posts: 170

Member car:

Alfa 147 Turismo

Flashing Odmeter Display

Started the car last night and the odmeter display was flashing. Stopped now but can't seem to find anything in the owners manual about this.

Anyone tell me what this is.

Drive a 147 1.6 120 turismo
gazzaputt147 is offline  
Sponsored Links
Status: ready4vacations
AO Platinum Member
Join Date: Jul 2002
Location: Portugal
County: Porto
Posts: 31,304

Member car:

Alfa 159 QV

Re: Flashing Odmeter Display

Do a search about "proxy alignment". You'll find that, during the start the system does a complete check up. If something fails but it's not a fundamental problem, the odometer will flash but everything will work. Next time you'll start your car it will probably be fine and you wont need to worry. But if it keeps flashing you might need to check it with your mechanic.
THROTTLEMAN is offline  
Status: -
AO Member
Join Date: Sep 2005
Posts: 12

Member car:

156 v6

Re: Flashing Odmeter Display

Happend intermittently on my 147 also. Switched the ignition off and on and flashing stopped. Never had any mechanical or electrical probs with the car so just put it down to one of those things.
IainMayer is offline  
Status: -
AO Member
wlm8361's Avatar
Join Date: Mar 2004
Location: Australia
County: Victoria
Posts: 924

Member car:

Brera 1750Tbi Ti

Re: Flashing Odmeter Display

Its been discussed in lengthy threads here before so I'd recommend searching for <flash>

Anyways, it simply means you didnt leave enough time for the CANBUS to do its checks. Just wait for all lights flashing to go off when you first, count to 3 and start her everytime. The flashing doesnt happen if you follow this 'ignition sequence'.
wlm8361 is offline  
Status: Waiting for a new Alfa which sounds like an Alfa.
AO Member
splashalot2000's Avatar
Join Date: Jun 2003
Location: Australia
County: Tasmania
Posts: 391
Re: Flashing Odmeter Display

I thought the instruments' flashing was caused by driving off before the check had finished.
splashalot2000 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

display , flashing , odmeter

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome