Selespeed paddle strange behaviour - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 22-06-13 Thread Starter
Status: -
AO Member
hub's Avatar
Join Date: Mar 2012
Location: Hong Kong
County: Sham Shui Po Kowloon
Posts: 60
Images: 8
Selespeed paddle strange behaviour

I have a facelift 156 Selespeed with the paddle shifts. I've owned the car for 18 months now and the paddles have worked perfectly. However, recently I was aware of that hot water smell and the windscreen had a small fog patch in the centre just above the information cowl. I then left the car for a couple of weeks and when I next used it the seats were covered in mould patches. This wiped off easily enough but obviously the interior was damp for the mould to have grown. The car is parked under cover so rain not an issue.

So that leads me onto the paddles - the up shift paddle has stopped working, or works occasionally and sometimes if shifting from 2nd will go to 4th. The stick shift works fine so I'm resorting to that. The downshift paddle is fine also.

So my question is are the paddle problems and the water smell/mould related? My guess is that the heater core maybe leaking which would cause the smell and mould to grow and I understand that the heater core can leak onto some of the electronics, so would that cause the paddle problems?

I recently fitted larger paddles so have had both shifters apart and all was in good condition so I'd be surprised if the upshift paddle is worn. Your help appreciated.
hub is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

behaviour , paddle , selespeed , strange

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome