147 Problems with Filling Up, - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 11-06-13 Thread Starter
Status: -
blink's Avatar
Join Date: Aug 2007
Posts: 7
147 Problems with Filling Up,

Hi All, i've had a problem for a few years with filling up unleaded. At nearly all service stations, i can't get more than about 5 litres in it, without the nozzle clicking off. I did find one that i had no problems with, and so i have stuck with it. But i received some bad fuel, so now i am looking again....

I've tried putting the nozzles in more, out more, twisting in each direction. Even finding service stations that have different angles on the concrete. I've even tried sticking my tongue out, and jumping on my left leg, to get it to work.

Any ideas? (except go back to the service station that works)
I believe there is a fuel vent pipe back to the engine bay, but if this is the issue, why would 1 service station work then?
blink is offline  
Sponsored Links
Status: - Update
Posts: n/a
No real answer, but I had a Ford Ka that did the same thing, eventually I developed a technique to fill it slightly faster. Every 4 or 5 litres, let go of the lever on the pump. I think the filler pipe had been squashed or twisted so that the fuel backed up the filler pipe and triggered the little clicker thing. Slowing the full rate or releasing the handle a moment key the filler drain into the tank fully.
Status: Anonima Lombarda Fabbrica Automobili
AO Member
keepRolling's Avatar
Join Date: Sep 2009
Location: South Africa
County: Gauteng
Posts: 975
I've got the same problem on a 156. sometimes the fuel even squirts back out the filler and makes a mess... Still searching for a proper solution.
keepRolling is offline  
Status: Enjoying a nice mug of tea
AO Silver Member
Join Date: Oct 2008
Location: United Kingdom
County: Bedfordshire
Posts: 1,752
When I was a teenager I used to run a filling station on a sunday afternoon which was not self service (very old school) and used to hate it when a Jag pulled up because I knew this was going to take an age to fill up because of the way the filler pipes ran, from this experience I quickly learned that some cars were a lot easier to fill than others.
CJO is offline  
Status: - Update
Posts: n/a
My 164 is terrible for this part of the problem is vapour from the tank I find if you put the nozzle in then push it up slightly rather than down the neck it helps let the vapour out? not perfect but helps. The tank is designed to build a bit of pressure and easiest route of escape is the open filler neck

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , filling , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome