Whooshing on new turbo (147 JTDm) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 07-06-13 Thread Starter
Status: 147 is a joy!
AO Member
Seraphization's Avatar
Join Date: Apr 2010
Location: South Africa
County: Gauteng
Posts: 72

Member car:

147 JTDm 16v

Whooshing on new turbo (147 JTDm)

Hi guys

Hope I can gather some advice before phoning up the garage.

I have a 2007 147 JTDm 16v, 106k on the clock. Was driving home on Sunday and the car behaved as if I was in neutral and flooring the gas...basically the engine was turning crazy with the wheels going nowhere. Lots of smoke etc. I thought initially the clutch was to blame, but after a diagnosis by Arnold Chatz, the turbo was apparently done for. Oil leaking, blood guts and puss, the lot.

Lots of money and a new turbo later, I got my car back yesterday, but not entirely sure all is kosher.

Basically it makes a short whooshing noise every time I change gear - and not necessarily only at high revs. Also noticed that if I rev the engine in 3rd/4th beyond 2000rpm I hear a constant whistling type of noise.

Now, I know a turbo can make this noise, but my old turbo never made any noise. It was completely silent. And I'm not entirely convinced the new turbo gives as much of a kick as the old one. It seems to deliver the boost in a slightly less powerful, continuous manner. My old turbo would really kick you into your seat in 2nd and 3rd. Not saying the new one is low on power, because there is power. Just doesn't feel as aggressive as the old one.

So essentially my question is, do I give the car a few more days to see if the noise disappears (for whatever reason)? And maybe the turbo just needs a bit of yardage to 'loosen up'? Sorry, I'm not terribly clued up on these things, so any advice would be appreciated.

I have read one or two things about boost leakage, or an air leak etc. Trouble is as I said the turbo is delivering a decent bit of power - also as far as I can see there is no more exchaust fumes than the usual diesel output.

Any help is really appreciated guys. I paid a lot for the turbo!
Seraphization is offline  
Sponsored Links
Status: -
AO Silver Member
Cream's Avatar
Join Date: Mar 2002
Location: wrexham
Posts: 1,279
Images: 2

Member car:

Brera 2.4SV

my turbo wooshes from about 1500 rpm, its the defining noise the engine makes

could be you have some loose hoses somewhere though, check all the clips are tight
Cream is offline  
Status: Boost Glorious Boost. Thanks Samco
AO Member
Paulo156jtdm's Avatar
Join Date: Aug 2012
Location: United Kingdom
County: Leicestershire
Posts: 76
Images: 2

Member car:

156 Jtd 16v

Almost undoubtedly a nice hole in your lower Hose (or upper for that matter).

Check these thoroughly as the hole in mine was tiny and hidden right under the awkward bend underneath so not visible. The Samco replacements from Alfaworkshop are great and restore the full Boost. Afraid they're not cheap if you've just spent a load of Monies but well worth it.

Paulo156jtdm is offline  
Status: 00v00
AO Silver Member
Join Date: Nov 2007
Location: South Africa
County: Johannesburg
Posts: 1,812
I had my JTDm's turbo hose replaced at Chatz earlier this year. It wooshes slightly when the turbo spools up. The power delivery is quite progressive for a diesel. As long you're car doesn't smoke too much and pulls strongly I wouldn't worry too much. Make sure that any smoke is black and not white or blue. If the turbo hose was holed your car would have very little power and would sound like a vacuum cleaner on takeoff.

You're welcome to have a go in mine and compare the two if you like.
alastpa is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , jtdm , turbo , whooshing

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome