GT LED fog light stays on - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 03-06-13 Thread Starter
Status: -
Join Date: May 2007
Location: Germany
County: Nordrhein-Westfalen
Posts: 7

Member car:

GT Q2 Cloverleaf

GT LED fog light stays on

Hello Forum,

So here's my problem. I have a beautiful GT Cloverleaf 2009. I am living in Germany and need to have European lights fitted. Headlights were an expensive no brainer but the rear fog/reversing lights are a different matter. I have purchased a European RHS (reverse) light therefore giving me two 'clear' bulb housings. In conjunction with a red bulb and a bit of a bodge job on the wiring loom I can easily swap my reverse and fog over - or so I thought.

I have purchased some mid to high range red LED bulbs (not error free) from eBay cognisant that I will get a canbus error that I hope to remove with a resistor loom that is on its way. All is good. Plug in bulb, nice and bright (brighter than original) and reverse is right, fog is left, anticipated canbus error appears - no sweat.

Now the sun has gone down and I take an admiring look at my car and notice that the red fog LED is still partially lit (on but dim). Put the original bulb back in and there is no sign of life. Obviously there is current flowing - though not enough to get a normal bulb going.

What's the issue here? Is there always current flowing through the wiring loom? Should there be? Does this explain why I have such bad battery problems?

Thoughts, ideas, suggestions welcome - except for removing the bumper to replace the LHS light fitting with a costly European one every time I go back and forth across the channel.

Thanks in advance.
jgrob1 is offline  
Sponsored Links
Status: The Rosso twins are here!
Club Member
Membro Premio
edraven71's Avatar
Club Member Number: 1612
Join Date: Oct 2011
Location: United Kingdom
County: Tyne and Wear
Posts: 3,658
Yes there is always a slight current flowing through the lights, not enough to light a filament bulb but enough to make an led glow slightly as you describe, you could as you either add a resistor which will also remove your light off warning or fit some canbus free bulbs, which is basically the same thing, just gives a resistance so the car 'feels' a bulb there and will stop the glowing.
edraven71 is offline  
(Post Link) post #3 of 3 Old 04-06-13 Thread Starter
Status: -
Join Date: May 2007
Location: Germany
County: Nordrhein-Westfalen
Posts: 7

Member car:

GT Q2 Cloverleaf

Very many thanks. Reassuring that there's no problems. Thanks for the swift reply.
jgrob1 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

european , fog , fog or reverse , led , light , stays

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome