Some tech data and help/advice needed asap please - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 29-05-13 Thread Starter
Status: -
Join Date: May 2013
Location: United Kingdom
County: Midlands
Posts: 5

Member car:


Some tech data and help/advice needed asap please

Please can someone provide me with some info on the following

I have an alfa 157 16v think 140bhp?

I have another thread about a none start issue which continues.

Code from a diagnostics machine mention fuel pump 3

Which is fuel pump 3
I thought their were only two pumps?

What is the fuelling procedure and pressure that I should get

I want to know pressure from lift pump to test the lift pump

After the lift pump it goes filter housing then to a junction box that sounds like it hisses on ignition should this be hissing?

As I get no pressure to the fuel rail what could be causing this? I have bench tested lift pump and it it squirts diesel out fast and at filter housing I have changed to clear pipes and it shoots diesel through and appears to be a good solid, fast supply but still only trickles at the rail.

New filter in filter housing and also does shoot fuel out of housing pipes so doubt the problem is their.

donny121 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

asap , data , help or advice , needed , tech

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome