156 jts high CO MOT fail - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 17-05-13 Thread Starter
Status: -
AO Member
Join Date: May 2010
Location: United Kingdom
County: Bedfordshire
Posts: 49
156 jts high CO MOT fail

My '55 156 2.0 JTS failed it's MOT on high CO.

Fast Idle
CO 0.46
HC 58
Lambda 1.0

Idle passed with CO 0.02

It runs fine, but does sometimes blow smoke under high revs/heavy throttle (only really noticeable at night in the lights of a car behind). Although it only seems blow smoke the first time it is booted, then won't do it for a while until it has been run at 'normal' revs for a while...

The garage suggested it is most likely to be the Cat, are they correct?
Any other suggestions- I guess the Cat will be expensive!

Any suggestions welcome!
glenm is offline  
Sponsored Links
Status: - Update
Posts: n/a
Big bottle of cataclean?

Followed by Italian tune up and a tank of V Power Nitro+ should have you sorted. That's not far off a pass is it?
Status: MOT passed :-)
AO Member
Join Date: Jan 2011
Location: United Kingdom
County: Greater London
Posts: 246
My 166 failed its MOT on pretty much the same thing back in March,and though the garage doing the MOT thought it might be the cat,it turned out to be the Lambda sensor that had failed.

The lambda sensor was 75.00,plus 50.00 labour to fit.

Bit cheaper than a Cat !
mocky166 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , fail , high , jts , mot

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome