Car won't start, need some advice - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 09-05-13 Thread Starter
Status: -
Join Date: Apr 2010
Location: United Kingdom
County: Torfaen
Posts: 2

Member car:

Clio 182

Car won't start, need some advice

I've got a 2007 1.9 JTdm GT, I had problems about month ago with car not starting and found out it was the battery that had died. Replaced the battery and that sorted things out so I thought until now. I went to start up the car and it would not start up and the lights on the dash were flickering from power loss. Car started up straight away with jump leads and took it straight to garage. Said battery and alternator was fine and maybe battery is draining for some reason. Battery was running at about 13V and alternator was reading 40 something. Told me to come back if it happened again. Later this evening it did the same again. Any reasons why my car just seems to lose power?
carrmrc96 is offline  
Sponsored Links
Status: dogging
AO Silver Member
Join Date: Jul 2012
Location: United Kingdom
County: Bristol
Posts: 1,375

Member car:

156 Sport 2005

Power drain somewhere by the sounds of things. Is your bulb out indicator on?

diddums100 is offline  
Status: -
AO Gold Member
Wezley's Avatar
Join Date: Sep 2011
Location: United Kingdom
County: Greater Manchester
Posts: 11,402
Images: 27

Member car:

159 2.4 JTDm

As above it does seem like a power drain somewhere. You can probably check it or have it checked with a multimeter.
Wezley is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

advice , car , start

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome