Newbie - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 18-08-05 Thread Starter
Status: -
Join Date: Aug 2005
Location: United Kingdom
County: Surrey
Posts: 4

Member car:



Hi all

Introducing myself as yet another new 156 owner, 2000 X Dark blue with blue momo leather & selespeed gearbox and I am loving it. Yes the selespeed did fail in the first week - sticking in gear & dropping in to neutral when stopping forcing me to abandon it at the nearest alfa garage in Aldershot. But to their credit I had it back later that day with just a relay replaced at 50 which was a huge relief, ok the relay was only 6 but I was happy!
I have to say I have never bonded with a car so quickly and I am really looking forward to learning more, and yes pictures will follow.
I had a word with AHmotersport today who I will probably use as my garage (unless anyone screams), Having read some recent threads I asked about oil & Brake upgrades. As standard he uses valavaline 10/40 semi synthetic and even uses it with his race cars, as to the brakes dont waste money with replacing the discs with others the same size just uprate the pads - preferably to ds2500's if you dont mind the squeek. Having said that deamon tweaks have a disclaimer on their site saying they can only sell them for off road use on post 2000 cars and imply they are not raod legal!

Anyway if you are still with me I have the obligatory newbie questions - I have the momo leather and carbon dash but no skirts and the suspension seems normal so what SP model do I have if any?
The steering wheel vibrates at 70-80MPH so I had the tracking done (25 at Kwik-Fit) but it is exactly the same. Could it be anything else before I take it back and look like a tw**

Cheers for now

Davo is offline  
Sponsored Links
Status: ready4vacations
AO Platinum Member
Join Date: Jul 2002
Location: Portugal
County: Porto
Posts: 31,304

Member car:

Alfa 159 QV

Re: Newbie

You've only missed the piccies.

Welcome on board.
THROTTLEMAN is offline  
Status: frenzied burrowing
AO Platinum Member
Fraser's Avatar
Join Date: Mar 2003
Location: United Kingdom
County: South Lanarkshire
Posts: 19,680
Images: 8
Re: Newbie

Hi Davo, welcome to the forum.

Don't know the model, but someone on here will probably help. As for the wheel vibration, did you get the wheels balanced when you got the tracking done? That's the most likely cause.
Fraser is offline  
Status: Tin worm attack ... ARGHH!
AO Gold Member
gazza82's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,285
Images: 12
Re: Newbie

What colour dials have you got? Black with red where fitted to SportPacks although your 2000-model might be on the "cusp".

Saloon or sportwagon ... ???

With early models 98-2000ish:

Standard: wood trim dash, white/silver dials with green illum, velour seats, 15" steel or alloy wheels (16" optional)

SP1: Carbon dash, leather steering wheel & gear knob, black with red illum (still green switches, etc), skirts and lowered suspension, 16" Teledial Alloys

SP2: Add anthracite Recaro sport seats and trim

SP3: Replace Recaros with Leather Momo interior

They did release different trim models later (Lusso, Tourismo, and Veloce).

Brakes: DSPerformance (DS2000's are road-legal) and I don't believe they squeak as badly.

Wheel wobble: Probably balancing as already suggested.

cheers, Gary

HIS: 1998 156 2.0 TSpark with Sport Pack 2, sunroof and hi-level spoiler in Alfa Rosso. V6 intake mod, clear side repeaters and Zeatek undertray.

HERS: 2009 MiTo 1.4 95bhp Turismo arrived 21st November in Techno Grey with colour-coded headlight surrounds.

"If you're driving on the edge ... you're leaving too much room!"
My Alfa156 Web Site - how-to's, piccies, links, useful stuff, etc.

Last edited by gazza82; 19-08-05 at 09:49.
gazza82 is offline  
Status: up to my eyeballs in work :-(
AO Gold Member
Green Cloverleaf's Avatar
Join Date: Jun 2004
Location: United Kingdom
County: Hampshire
Posts: 7,160
Images: 13
Re: Newbie

Welcome to AO, Davo from a fellow Hampshire resident!

Looking forward to those pics
Green Cloverleaf is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome