engune management light high emmissions - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 17-08-05 Thread Starter
Status: -
AO Member
darenheat1's Avatar
Join Date: Jan 2005
Location: United Kingdom
County: Nottinghamshire
Posts: 24
Images: 4
engune management light high emmissions

i have a 98 156 1.8TS which has never ran right since i bought it a year ago. about 3 weeks ago the fuel management warning light came on and with it the cooling fan on the radiator (just as mot was coming up too). when i first start the car after a rest the fan and light doesnt come on but after 5 mins or so there both on. i get the dancing idling and the poor fuel economy and hesitation on pulling off. It went for mot and failed emmissions on fast idle revs they were all high and wouldnt drop whatever the rev range. as far as im aware the idle test was ok but revs were holding steady at the time so lucky there.
In the last 6 months i have renewed plugs cleaned idle butterfly valve and just replaced the lambda sensor.
i think it may be the air flow meter but not sure. if any1 can point me in right direction it would be appreciated as i dont wanna fork out at alfa for them to change stuff i dont need.
darenheat1 is offline  
Sponsored Links
Status: Tin worm attack ... ARGHH!
AO Gold Member
gazza82's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,290
Images: 12
Re: engune management light high emmissions

Fast idling ... tell me about it. My idle wouldn't drop below 1400rpm ... and this year proved a real b*tch to get through the MOT ... there's a post on this site about the saga (Failed MOT) and some stuff on my website (see my signature link).

For me it turned out to be the "oil vapour separator valve".

But because your symptoms were sudden, I'd say it was electrical. Have you had it on an diagnostic system (Examiner at Alfa)??? Think you might have to start there .. they will probably charge you around 40-60 to test it, unless you know or live near someone with their own testing kit/software.

cheers, Gary

HIS: 1998 156 2.0 TSpark with Sport Pack 2, sunroof and hi-level spoiler in Alfa Rosso. V6 intake mod, clear side repeaters and Zeatek undertray.

HERS: 2009 MiTo 1.4 95bhp Turismo arrived 21st November in Techno Grey with colour-coded headlight surrounds.

"If you're driving on the edge ... you're leaving too much room!"
My Alfa156 Web Site - how-to's, piccies, links, useful stuff, etc.
gazza82 is offline  
Status: Loving My 159
AO Member
michaeld's Avatar
Join Date: Sep 2004
Posts: 654
Images: 5
Re: engune management light high emmissions

Poor idling and sluggish performance can be caused by the lambda sensors or else the MAF. Unfortunately the only real way to find out is by replacement. Go to a good independent garage and they'll change the MAF .... if it doesn't work then they'll try something else (the lambda sensors).
michaeld is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

emmissions , engune , high , light , management

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome