Diff Bearing Failure? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 30-04-13 Thread Starter
Status: -
AO Member
Join Date: Oct 2010
Location: France
County: Burgundy
Posts: 21
Diff Bearing Failure?

Hi from a wet and cold France!

Has anyone experienced diff bearing failure with a 10v 2.4?

I suspect I have this problem so it would nice to hear from anyone who can pass on their knowledge to help with the right diagnoses!

Thanks in advance.
chopper chad is offline  
Sponsored Links
Status: Busy busy busy!
Club Member
Membro Premio
Pud237's Avatar
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 41,613
I can't say I've come across diff bearing failure, but I have come across a few instances where the diff itself has failed.

The diff bearings are quite cheap, and the job is not difficult to do either as it doesn't require gearbox removal so if you suspect them, might be worth changing them (or fitting a Quaife LSD at the same time).

How many miles does the car have?
Pud237 is online now  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

bearing , diff , failure

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome