alfa romeo 156 1.6 help - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 24-04-13 Thread Starter
Status: -
AO Member
Join Date: Sep 2011
Location: Greece
County: Ionian Islands
Posts: 20
Crazed alfa romeo 156 1.6 help

Hi folks from poor Greece ,i have a problem tha made so sad that i will not buy again alfa romeo to my life. After doing a big service to my car 1300 euro replaced 3 lamda sensors all original bosch . I had a weird problem with a valve that was throwing oil to my ecu wiring line and the ecu was full of oil.Finally fixed new wiring was set up all good exept a crazy P0141 error who comes after a few km .i Swapped the lamda sensor why the fiat scan says tha is the lamda sensor in belt side with the other other on the gear box side but nothing . Reset the Ecu many time cleaned with contact cleaner but still there . I m getting crazy with this ,talked to my mechanic and told me that propably is the ecu and needs to be replaced but is so expensive .Do you have any ideas what cause this or finally need to replace the ecu ? thank you for your time.
andygilios is offline  
Sponsored Links
Status: Busso
AO Silver Member
Join Date: Apr 2012
Location: United Kingdom
County: Berkshire
Posts: 2,547
I have no idea if it is the ECU or not, but I would imagine they are much cheaper from breakers than Alfa! If you can find an Alfa specialist, then they will probably try swapping one as a test. Most Alfa places in the UK have a "graveyard" round the back....
rxe is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alfa , romeo

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome