Over fuelling - Strong smell of petrol - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 05-04-13 Thread Starter
Status: -
AO Member
James 156's Avatar
Join Date: Jun 2010
Location: United Kingdom
County: Kent
Posts: 122
Over fuelling - Strong smell of petrol

I tried starting the car on wednesday following a 5 minute stop after a previous 20 minute car journey (So engine was warm) and I just got the Engine Management light, turning over but no ignition. Usually its related to the yellow key light which I never get round to fixing (antenna) but this time that light was out.

After a couple of goes I left the car there. Went back later in the evening and put the key in but the red light was still illuminated so didn't bother trying to start it - I didn't realise until checking this forum when I got back that all the red light meant was a code was stored and I probably could have started the car!

The next day I took my laptop along with MultiEcuScan and got a couple of errors, P0335 no signal which pointed to the crank (I checked the connector and all looked fine). The other was U1600 (Invalid Signal) which must point to one of the numerous times the antenna has been playing up and I've tried starting the car without checking its gone out.

I'm just ordering a new sensor now but this last 2 weeks (maybe 3 as I always try and ignore these problems) there has been a very strong petrol smell after any journey in the car as if its seriously over fueling - Is that related to the Crank Sensor failing and the ECU running on some sort of safety default programme or have I got another problem on my hands??
James 156 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

fuelling , petrol , smell , strong

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome