156 jtd 16v m-jet - lost all power and smoke belowing out of tail pipe - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 30-03-13 Thread Starter
Status: -
AO Member
47ak's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: Berkshire
Posts: 11
156 jtd 16v m-jet - lost all power and smoke belowing out of tail pipe

Hi all. also have an Alfa 156 jtd 16v m-jet, I was driving a week ago I lost all power and smoke was belowing out of the back tail pipe I had no accelartion at all and had to switch it off and call the AA. The garage cleaned the EGR valve and they also noticed that the thin turbo pipe at the top the engine was completely flat, so they replaced the hose the car was accelerating like a rocket. Today an orange light came on which looks a bit like an engine block and I cant get that usual warp drive feeling anymore. it seems to drive much much slower and I dont have that Warp factor anymore. Does anyone know what this might be
47ak is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 16v , belowing , jtd , lost , mjet , pipe , power , smoke , tail

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome