My 156 alarm & battery issues? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
My 156 alarm & battery issues?


Just picked up a 00 2ltr 156 on Friday and have had a few issues with it since. The alarm was behaving seriously erratically (its an aftermarket one). For example I parked the car in my drive, lock/alarm it and the alarm goes off for no reason and I am unable to disable it (unless I disconnect the main battery).

I decided to park my car in work where it would be safe (unalarmed) over the weekend and when I went to pick it up yesterday the battery was totally dead! Connected issues?

I've got the battery on charge now and I'm trying to get the alarm key from the dealer so I can totally disable it. Any advice/ideas/encouragement? The garage doesn't want to know about it but I'm short of toeing the car down and bouncing the keys of yer mans head at this stage!
Sponsored Links
Status: -
AO Member
daveg360's Avatar
Join Date: Jun 2004
Posts: 511
Re: My 156 alarm & battery issues?

If its from a car dealer (either an Arthur Dailey or a main dealer) threaten to reject it based upon it being unfit for the purpose intended. Go to your local trading standards. Do not take any abuse these monkeys, they have obligations
daveg360 is offline  
Status: - Update
Posts: n/a
Re: My 156 alarm & battery issues?

ok, update so far is my battery is completly nackered it's not charging properly according to a local mechanic. I've gotten the key "he *thinks* may be the right one" from the dealer for the alarm to knock it off.

I'm gonna have to buy a new battery for starters and then see about the alarm. I'll talk to my trading standards office too, I think this is going to get messy !
Status: -
AO Member
Tee-O's Avatar
Join Date: Aug 2003
Location: Naas, Ireland
Posts: 890
Images: 10

Member car:

GT Monza 1.9JTDm

Re: My 156 alarm & battery issues?

Hopefully the new battery will cure your problem. Just to let you know that when I have let the battery go down on mine, the alarm goes beserk and won't switch off until I jump start it and get it running again and at that, it takes 5 or 6 attempts to reset the alarm.

It normally happens if one of the kids has let the interior light on and the batt goes flat.
Tee-O is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alarm , battery , issues

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome