Timing belt kit question - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
AO Member
Join Date: Mar 2012
Location: New Zealand
County: Bay of Plenty
Posts: 13

Member car:

156 Selespeed

I've used the calibrate routine in Multiscanecu in the past but it always seemed a rather vulgar way of going about things, brake on, 3k in 2nd floor it ... Yikes!. All a bit subjective I thought considering you are trying to program a Plc controlling an electo/hydraulic robot ...
I've tried this 5 start method on both the 00 and 04 model now and to me they are both equally as good as the software method ...
Would be interested to hear your results.
Originally Posted by Mufasa View Post
I really like my Selespeed too-must try the 5 start trick to see if it works....
Alfanut156 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Oct 2013
Location: United Kingdom
County: Surrey
Posts: 34
156 & 147 Selespeed and new owners essential thread

Alfanut - stumbled across this thread whilst looking for cambelt info. WOW!

been looking for a 147 and seeing 2 more tomorrow (2nd Nov '13), both 2.0 Sele's, both low milers but one that has hardly moved for the last 3 years and the other - 67K - seems on paper to be a good 'un.

I hope to not forget to report back on what i end up buying and my Chapter 2 of the Alfa Romance.

Chapter 1 began in 2000 with a brand new 156 1.8TS. Sad start with a porous cylinder head (no, really...) but all good after that and for the next 40K miles.
NikBl is offline  
(Post Link) post #28 of 28 Old 12-11-13 Thread Starter
Status: -
AO Member
Join Date: Mar 2013
Location: United Kingdom
County: Lancashire
Posts: 17

Member car:

Alfa Romeo 156

Originally Posted by Alfafamily View Post
Don't you just love old threads where the OP never returns with the end of the story to tell the rest of the posters what he did or what was found when the car was worked on.

Nothing annoys me more about this forum. If you need advice because of limited knowledge then that's what the forum was set up for. But not to put anything back to report experiences after taking the advice is just not on.

OK, here you go, I killed the car!!! Left the cam belt whilst I wondered what to do with lots of people saying 'risk it - afterall, if it goes, what have you lost?' I'll tell them what I lost, one one the best cars I've ever owned. What I paid is irrelevent. Long story short, after a weekend away in June, (I think) I rang an Alfa specialist on Monday morning for the cam belt change. He booked it in for 2 weeks from that day. I jumped in the car to get some shopping and 1 mile down the road the belt slipped. End of car.

DanRrr is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

belt , kit , question , timing

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome