156 2.5 v6 Injector light on dash - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 07-03-13 Thread Starter
Status: -
AO Member
mickjm's Avatar
Join Date: Aug 2009
Location: United Kingdom
County: Conwy
Posts: 15
156 2.5 v6 Injector light on dash

This has probably been covered in previous threads however, before I trawl through hopefully someone might be able to shine some light on me problem.
Recently the car started bein a pain to start. Then when it did the dash reset to 0.0 miles on the trip meter but it ran fine. Soon after this became the norm, the injector light came on intermittently and now its on permanently. It runs as tho its in limp mode. When sat idle its ok, but when its revved its very sluggish but eventually revs out.
I've not had it on a diagnostic yet but wondered if there were any explanations or similar incidents. One of the injectors appears loose on the front bank i.e its easily turned in its seat whereas the others all appear solid??!! Thanks in advance
mickjm is offline  
Sponsored Links
Status: DEFCON5
AO Gold Member
1of1's Avatar
Join Date: Oct 2010
Location: Sao Tome and Principe
County: Principe
Posts: 11,605
Images: 7
No point in guessing really, could possibly be the throttle potentiometer wiring...

Have you unplugged the MAF?
1of1 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , dash , injector , light

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome