Management says lambda - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 01-03-13 Thread Starter
Status: -
Join Date: Mar 2013
Location: United Kingdom
County: Lancashire
Posts: 5

Member car:

156 JTS Turismo

Help Management says lambda

I've recently bought a 156 and the engine light has come on and says lambda also when its warmed up the engine splutters when you try putting your foot to the floor as if the injectors are blocked but if you lift off for a sec then try again it pulls like a train!!
Can anyone suggest anything??
Thanks Alan!!

Bigalistan is offline  
Sponsored Links
Status: Still very confused
AO Member
Join Date: Feb 2005
Location: United Kingdom
County: Cheshire
Posts: 850

I understand your problems, mine is very similar, warning light, lambda sensor warnings etc. I have checked and changed MAF, spark plugs, thermostat, and a coil pack. The coil pack cured a random misfire but it still have a low end hesitation and a random tick over. All other issues seem to have gone. The other thing I did was use a fuel system cleaner and every now and then put about 250ml of Parafin into the fuel. I have bought a used set of injectors and had them serviced as these seem to be the course of all evils on the JTS engine. Ar some time in the ear future I will fit these and hope that it will cure the slow running issues. I also spent some time checking all the pipes on the inlet manifold for leaks etc.. One thing that is strange, the cars performance feels better than ever..... Strange.
Good luck
Philjay50 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

lambda , management

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome