Engine Management Light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 28-02-13 Thread Starter
Status: Wired to the moon
AO Member
Scabies's Avatar
Join Date: Aug 2008
Location: United Kingdom
County: Renfrewshire
Posts: 624
Engine Management Light

Tuesday evening 26 February 2013, dropped a mate at Birmingham Airport and then headed over for a night out in Nottingham.

Bombing along the M6 doing just above 70the Engine Management Light started to flash, in the words of Tony the Tiger "Greaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaat!!!!!!! !

I eased of the juice, and the liht went out, its now Thursday 400 miles later and no sign of the light.

I have just put the code reader on and hey No Codes stored.

Well chaps WTF!

Any ideas on a post card please.

The engine is a 2 litre JTS done about 48k all serviced belts etc up to date

"To be a Ranger is to sense the sacred trust of upholding all that such a name means in this shrine of football. They must be true in their conception of what the Ibrox tradition seeks from them. No true Ranger has ever failed in the tradition set him."
Scabies is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

engine , light , management

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome