147 with various issues. Assistance appreciated - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 25-02-13 Thread Starter
Status: -
AO Member
Join Date: May 2009
Location: United Kingdom
County: West Midlands
Posts: 44
147 with various issues. Assistance appreciated

Hi guys,

We bought a cheapish 147 jtdm about 8 months ago to replace our past it stilo jtd 8v.

Been great without really a penny spent on it but really need some love now so some assistance on some needed maintenance would be helpfull.

First of all we have no reverse lights and noticed the cable has been pulled from the connector. On replacement do the cables have to have the right polarity or can be connected either way?

Also the alfa is quite a smokey old girl. Little bit of reading has brought up a few answers for this.

Is the egr in the same position as the 8v and suitable for cleaning?
I need to look at the turbo hoses also as the car feels like there is a boost leak on acceleration with alittle hesitance.

Our rear backbox also rattles from side to side, am I right to assume just exhaust hangers is the likely cause.

I am hoping a lot of these jobs I can carry out myself with parts costs alone.

Any help would be much appreciated.Thank you
coupedummy is offline  
Sponsored Links
Status: Still trying to find that Noise...
AO Member
Chris_gta's Avatar
Join Date: Jun 2011
Location: United Kingdom
County: Essex
Posts: 920
Hi, im not a diesel person but I'll do my best to help.

If the reverse switch connector isn't 'keyed' then there's no polarity its just a simple make switch.

EGR is worth looking at and cleaning, does get very sooted, some carb cleaner does a good job.

You can buy silicone turbo hoses from autolusso's online shop

Exhaust hangars are about 7 ish each, also from autolusso

Good luck.
Chris_gta is offline  
Status: I'm ba-ack!
AO Member
Duke147's Avatar
Join Date: Dec 2012
Location: United Kingdom
County: North Yorkshire
Posts: 95
I'm not sure about the 8V, but on my 16V the EGR is located at the back of the engine 'lump,' near the top. With the cover removed and looking straight down on the engine it would be in the top right of your view. I swapped mine recently and it was really easy to do, so I'm assuming it's similar to the 8V.

It might be worth checking your air filter as well.
Duke147 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , appreciated , assistance , issues

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome